Problème avec les Commands dans un item

Section dédié à la gestion de ces caches un peu particulières...
ManUdu69
membre
membre
Profil GC
Membre: : Basic
Messages : 7
Enregistré le : jeu. 24 janv. 2019 19:47

Problème avec les Commands dans un item

jeu. 30 mai 2019 14:02

Bonjour

Je rencontre un problème avec l'utilisation de "Commands" dans item.
J'ai créé un item avec un bouton  "Check position" qui lance un appel à une fonction (code LUA) qui vérifie la position du joueur.
Cela fonctionne bien sur l'émulateur urwigo, mais j'ai un plantage systématique sur smartphone (java.lang.ClassCastException : java.lang.String cannot be cast to se.krka.kahlua.vm.LuaTable)
Le problème ne vient pas de ma fonction mais bien de l'utilisation dans Execute du "LUA User Code" qui lance ma fonction
img2.png

Si je mets autre chose que "LUA User Code", cela fonctionne bien

Auriez vous une idée de l'origine du problème ? j'ai essayé pas mal de chose sans succès.

Merci
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Avatar du membre
TofLaBeuze
Administrateur du site
Administrateur du site
Contact :
Profil GC
Membre: : Premium
GPS : Samsung J5 + Etrex 30x
Localisation : Paris
Messages : 6622
Enregistré le : sam. 22 oct. 2011 12:35

Re: Problème avec les Commands dans un item

jeu. 30 mai 2019 18:47

Hello,
j'ai fait un petit test rapide, pas vu de plantage...
Quand tu parles de bouton  "Check position", c'est une bien une commande sur l'item ?
Sinon difficile à dire, ça pourrait être une variable pas incrémentée, ça passe par chance sur émulateur et pas sur smartphone...
J'avais entendu parler aussi de fonctions qui sont implémentées sur Android et pas sur Apple ?
Image Image
ManUdu69
membre
membre
Profil GC
Membre: : Basic
Messages : 7
Enregistré le : jeu. 24 janv. 2019 19:47

Re: Problème avec les Commands dans un item

jeu. 30 mai 2019 21:54

TofLaBeuze a écrit :
jeu. 30 mai 2019 18:47
Hello,
j'ai fait un petit test rapide, pas vu de plantage...
Quand tu parles de bouton  "Check position", c'est une bien une commande sur l'item ?
Sinon difficile à dire, ça pourrait être une variable pas incrémentée, ça passe par chance sur émulateur et pas sur smartphone...
J'avais entendu parler aussi de fonctions qui sont implémentées sur Android et pas sur Apple ?
Bonjour Tof
Oui il s'agit bien d'une commande sur un item (j'ai également essayé sur un character, mais même problème).
Le simple fait d'utiliser lua User Code fait planter.
Par exemple cette simple commande plante sur smartphone !
img1.png
Aurais tu éventuellement une cartouche (toute simple) qui fonctionne chez toi (fichier urwigo) à me passer pour que je fasse un test ?
J'ai l'impression que cela vient de la compilation du fichier en gwc
 
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Avatar du membre
TofLaBeuze
Administrateur du site
Administrateur du site
Contact :
Profil GC
Membre: : Premium
GPS : Samsung J5 + Etrex 30x
Localisation : Paris
Messages : 6622
Enregistré le : sam. 22 oct. 2011 12:35

Re: Problème avec les Commands dans un item

ven. 31 mai 2019 08:58

Suis en vadrouille mais j'essaierai de te passer ça en fin de we.
Je m'aperçois que je n'ai pas testé sur smartphone hier ! Normal que ça marchait :)
Image Image
Avatar du membre
TofLaBeuze
Administrateur du site
Administrateur du site
Contact :
Profil GC
Membre: : Premium
GPS : Samsung J5 + Etrex 30x
Localisation : Paris
Messages : 6622
Enregistré le : sam. 22 oct. 2011 12:35

Re: Problème avec les Commands dans un item

dim. 2 juin 2019 16:11

Exemple envoyé par mp.
Image Image

Retourner vers « Caches Wherigo »

Aller à ...

Annuaire

annuaire geocaching

Éditeur HTML

editeur HTML

Galerie des concours

galerie photos

Inscription Newsletter

newsletter

 

Au total il y a 135 utilisateurs en ligne : 2 enregistrés, 0 invisible et 133 invités
Membres : Bing [Bot], CIOL64
Le record du nombre d’utilisateurs en ligne est de 384, le ven. 19 sept. 2014 19:40
89806 messages
6886 sujets
4820 membres
Le membre enregistré le plus récent est PPFMP5.
Pas d’anniversaire à fêter aujourd’hui